With the release of the version 5.2, WordPress rose its requirement for PHP from 5.2 to 5.6. That means that all user having an older version of PHP on their server – 13% of WordPress users at the time I am writing these lines – cannot update their WordPress to 5.2 or newer without changing their PHP version.
Until then, the Polylang policy had always been to require the same PHP version as WordPress and thus allow all WordPress users to use Polylang too. We believe indeed that it’s not up to us to judge the validity of using an obsolete version of PHP. Until WordPress 5.2, everything was simple as the PHP requirement did not move for many years.
But with the arrival of the new requirement, the version management started to be more complex. Indeed Polylang is not only compatible with the latest WordPress version, but also with older versions, currently down to 4.7. Should we deprive the users of old WordPress versions from the latest Polylang?
Many WordPress users don’t update because of a plugin not yet compatible with the latest WordPress. Many users did not update by fear of the block editor. At the time I am writing, 37% of users are running WordPress 4.9 or lower, while WordPress 5.0 is almost one year old. Do these users run the latest Polylang? We know that some do. How many? We don’t know. How many are running an old version of PHP? We don’t know.
All these questions without sure answers make decisions hard to take. However we had a plan. It was to rise our PHP requirement to 5.6 for the next major release of Polylang (version 2.7), after a proper announce, together with the first beta, about one month before the final release.
But came WordPress 5.3. And with this version came some changes that produced a warning with Polylang. Not a big deal. That was just a warning. Warnings are just informations for the developers and not displayed on live sites. At least this is what we believed. And since the only way to remove this warning was to require PHP 5.6, we believed that we could live with it until Polylang 2.7 would be released. So we fixed it in our development version and released Polylang 2.6.6 without the fix.
But we were wrong. Live site do display warnings. And a lot of people don’t know how to hide them. So the support forum and our support team were overwhelmed by requests about this warning. First, we tried to educate people that a live site should not display warnings, but soon it became obvious that we could not easily manage the increase of support, and that we made users unhappy.
So here comes Polylang 2.6.7. The warning in WordPress 5.3 is fixed. The price to pay is that, starting from this version, Polylang now requires PHP 5.6 or newer. We had to do that sooner and less prepared than our initial plan. This is a good lesson for us.